Read the docs
TI-2022-01844 Aliases CVE-2022-1989GHSA-j7qg-8r9m-wxm8

CODESYS Visualization vulnerable to user enumeration

Priority LOW 26CWE-204Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-204.

Summary

All CODESYS Visualization versions before V4.2.0.0 generate a login dialog vulnerable to information exposure allowing a remote, unauthenticated attacker to enumerate valid users.

Why it matters now

EPSS 0.00865 58th percentileScored 2026-11-07
Fix Fixed CODESYS Visualization (CODESYS): V4.2.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
CODESYSCODESYS VisualizationV3 to before V4.2.0.0V4.2.0.0Patch availableCNA
  • CODESYS Visualization VendorCODESYS Affected V3 to before V4.2.0.0 Fixed in V4.2.0.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:codesys:visualization:*:*:*:*:*:*:*:*4.0.0.0 to before 4.2.0.0VulnerableCODESYS
  • cpe:2.3:a:codesys:visualization:*:*:*:*:*:*:*:* Versions 4.0.0.0 to before 4.2.0.0 Vulnerable ·CODESYS

Remediation

  • Fix · CNA CODESYS Visualization (CODESYS) Fixed in V4.2.0.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1989
  2. 2026-10-03 Alias added: GHSA-j7qg-8r9m-wxm8

References

  • TI-2026-00256 CODESYS Visualization - Insufficiently Protected Credentials CVSS 4.0MEDIUM 6.9

Sources