DX Share Selection <= 1.4 - Cross-Site Request Forgery to Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The DX Share Selection plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.4. This is due to missing nonce protection on the dxss_admin_page() function found in the ~/dx-share-selection.php file. This makes it possible for unauthenticated attackers to inject malicious web scripts into the page, granted they can trick a site's administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2001
- 2026-10-03 Alias added: GHSA-crr5-mf4p-x3rf
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Advisory 2
More nofearinc vulnerabilities
- TI-2025-13549 Missing authorization in nofearinc WP-CRM System – Manage Clients and Projects CVSS 3.1MEDIUM 5.4
- TI-2026-07917 WP-CRM System <= 3.4.6 - Authenticated (Contributor+) Exposure of Sensitive Information via 'contact_id' Parameter CVSS 3.1MEDIUM 4.3
- TI-2026-03587 DX Unanswered Comments <= 1.7 - Cross-Site Request Forgery via Settings Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-2001 · CVE Program
- CVE-2022-2001 · NVD
- FIRST EPSS
- GHSA-crr5-mf4p-x3rf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences