Insufficient Session Expiration in nocodb/nocodb
Priority MEDIUM 41CWE-613Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.
Why it matters now
EPSS 0.01243 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed nocodb/nocodb (nocodb): 0.91.7+nocodb (npm): 0.91.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nocodb | nocodb/nocodb | before 0.91.7+ | 0.91.7+ | Patch available | CNA |
| — | nocodb (npm) | before 0.91.9 | 0.91.9 | Patch available | GHSA-6293-2vg2-pmp5 |
- nocodb/nocodb Vendornocodb Affected before 0.91.7+ Fixed in 0.91.7+ Patch available CNA
- nocodb (npm) Vendor— Affected before 0.91.9 Fixed in 0.91.9 Patch available GHSA-6293-2vg2-pmp5
Remediation
- Fix · CNA nocodb/nocodb (nocodb) Fixed in 0.91.7+
- Fix · GHSA-6293-2vg2-pmp5 nocodb (npm) Fixed in 0.91.9 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
nocodb/nocodb 0.91.7+
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-01910 Improper Privilege Management in nocodb/nocodbPriority MEDIUM 41
- TI-2022-01909 Generation of Error Message Containing Sensitive Information in nocodb/nocodbPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2064
- 2026-10-03 Alias added: GHSA-6293-2vg2-pmp5
References
More Nocodb vulnerabilities
- TI-2023-17918 NocoDB through 0.106.0 (or 0.109.1) has a path traversal vulnerability that allows an… CVSS 3.1HIGH 7.5
- TI-2023-27191 NocoDB Vulnerable to Stored Cross-Site Scripting in Formula.vue CVSS 3.1HIGH 7.6
- TI-2026-19968 NocoDB has Blind SSRF via Unvalidated HEAD Request in uploadViaURL Functionality CVSS 3.1MEDIUM 6.4
- TI-2023-04694 Improper Input Validation in nocodb/nocodb CVSS 3.1MEDIUM 6.5
- TI-2025-20338 NocoDB Vulnerable to Reflected Cross-Site Scripting on Reset Password Page CVSS 3.1MEDIUM 6.1
- TI-2023-27663 NocoDB Allows Preview of File with Dangerous Content CVSS 3.1MEDIUM 5.7
Sources
- CVE-2022-2064 · CVE Program
- CVE-2022-2064 · NVD
- FIRST EPSS
- GHSA-6293-2vg2-pmp5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences