Read the docs
TI-2022-01934 Aliases CVE-2022-2090GHSA-mc26-m43p-75hh

Woo Discount Rules < 2.4.2 - Reflected Cross-Site Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Discount Rules for WooCommerce WordPress plugin before 2.4.2 does not escape a parameter before outputting it back in an attribute of the plugin's discount rule page, leading to Reflected Cross-Site Scripting

Why it matters now

EPSS 0.00788 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Discount Rules for WooCommerce (Unknown): 2.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDiscount Rules for WooCommerce2.4.2 to before 2.4.22.4.2Patch availableCNA
  • Discount Rules for WooCommerce VendorUnknown Affected 2.4.2 to before 2.4.2 Fixed in 2.4.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flycart:discount_rules_for_woocommerce:*:*:*:*:*:wordpress:*:*before 2.4.2Vulnerableflycart
  • cpe:2.3:a:flycart:discount_rules_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 2.4.2 Vulnerable ·flycart

Remediation

  • Fix · CNA Discount Rules for WooCommerce (Unknown) Fixed in 2.4.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-2090
  2. 2026-10-03 Alias added: GHSA-mc26-m43p-75hh

References

  • TI-2024-07918 Cross-site scripting in flycart Discount Rules for WooCommerce CVSS 3.1MEDIUM 6.1

Sources