Page Generator Plugin < 1.6.5 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Page Generator WordPress plugin before 1.6.5 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Page Generator (Unknown): 1.6.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Page Generator | 1.6.5 to before 1.6.5 | 1.6.5 | Patch available | CNA |
- Page Generator VendorUnknown Affected 1.6.5 to before 1.6.5 Fixed in 1.6.5 Patch available CNA
Remediation
- Fix · CNA Page Generator (Unknown) Fixed in 1.6.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2100
- 2026-10-03 Alias added: GHSA-hph2-3gwc-9fvg
References
More WP Zinc Page Generator vulnerabilities
- TI-2023-28570 WordPress Page Generator Plugin <= 1.7.1 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
Sources
- CVE-2022-2100 · CVE Program
- CVE-2022-2100 · NVD
- FIRST EPSS
- GHSA-hph2-3gwc-9fvg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences