LinkWorth Plugin < 3.3.4 - Arbitrary Setting Update via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The LinkWorth WordPress plugin before 3.3.4 does not implement nonce checks, which could allow attackers to make a logged in admin change settings via a CSRF attack.
Why it matters now
EPSS 0.0039 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LinkWorth Plugin (Unknown): 3.3.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LinkWorth Plugin | 3.3.4 to before 3.3.4 | 3.3.4 | Patch available | CNA |
- LinkWorth Plugin VendorUnknown Affected 3.3.4 to before 3.3.4 Fixed in 3.3.4 Patch available CNA
Remediation
- Fix · CNA LinkWorth Plugin (Unknown) Fixed in 3.3.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2172
- 2026-10-03 Alias added: GHSA-c2v8-4gvf-47f7
References
Sources
- CVE-2022-2172 · CVE Program
- CVE-2022-2172 · NVD
- FIRST EPSS
- GHSA-c2v8-4gvf-47f7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences