Simple Post Notes < 1.7.6 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Simple Post Notes WordPress plugin before 1.7.6 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Simple Post Notes (Unknown): 1.7.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Post Notes | 1.7.6 to before 1.7.6 | 1.7.6 | Patch available | CNA |
- Simple Post Notes VendorUnknown Affected 1.7.6 to before 1.7.6 Fixed in 1.7.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bracketspace:simple_post_notes:*:*:*:*:*:wordpress:*:* | before 1.7.6 | Vulnerable | BracketSpace |
- cpe:2.3:a:bracketspace:simple_post_notes:*:*:*:*:*:wordpress:*:* Versions before 1.7.6 Vulnerable ·BracketSpace
Remediation
- Fix · CNA Simple Post Notes (Unknown) Fixed in 1.7.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2186
- 2026-10-03 Alias added: GHSA-fg8x-25mv-x5rh
References
Sources
- CVE-2022-2186 · CVE Program
- CVE-2022-2186 · NVD
- FIRST EPSS
- GHSA-fg8x-25mv-x5rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences