Accept Stripe Payments < 2.0.64 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Accept Stripe Payments WordPress plugin before 2.0.64 does not sanitize and escape some of its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Accept Stripe Payments (Unknown): 2.0.64
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Accept Stripe Payments | 2.0.64 to before 2.0.64 | 2.0.64 | Patch available | CNA |
- Accept Stripe Payments VendorUnknown Affected 2.0.64 to before 2.0.64 Fixed in 2.0.64 Patch available CNA
Remediation
- Fix · CNA Accept Stripe Payments (Unknown) Fixed in 2.0.64
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2194
- 2026-10-03 Alias added: GHSA-8pf9-cjf8-hr4g
References
Sources
- CVE-2022-2194 · CVE Program
- CVE-2022-2194 · NVD
- FIRST EPSS
- GHSA-8pf9-cjf8-hr4g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences