An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to…
Priority LOW 36Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to extract the value of an unprotected variable they know the name of in public projects or private projects they're a member of.
Why it matters now
EPSS 0.01336 71st percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.10.5, 15.0.4, 15.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.7 to before 14.10.5; 15.0 to before 15.0.4; 15.1 to before 15.1.1 | 14.10.5, 15.0.4, 15.1.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.7 to before 14.10.5; 15.0 to before 15.0.4; 15.1 to before 15.1.1 Fixed in 14.10.5, 15.0.4, 15.1.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.7.0 to before 14.10.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.7.0 to before 14.10.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.0.0 to before 15.0.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.0.0 to before 15.0.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.1.0:*:*:*:community:*:*:* | 15.1.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.1.0:*:*:*:enterprise:*:*:* | 15.1.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.7.0 to before 14.10.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.7.0 to before 14.10.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.0.0 to before 15.0.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.0.0 to before 15.0.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.1.0:*:*:*:community:*:*:* Versions 15.1.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.1.0:*:*:*:enterprise:*:*:* Versions 15.1.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.10.5, 15.0.4, 15.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2229
- 2026-10-03 Alias added: GHSA-c63c-249m-g37m
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2229 · CVE Program
- CVE-2022-2229 · NVD
- FIRST EPSS
- GHSA-c63c-249m-g37m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences