Cross-site scripting in GitLab
Priority LOW 39CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Insufficient sanitization in GitLab EE's external issue tracker affecting all versions from 14.5 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to perform cross-site scripting when a victim clicks on a maliciously crafted ZenTao link
Why it matters now
EPSS 0.00918 60th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.10.5, 15.0.4, 15.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 14.5 to before 14.10.5; 15.0 to before 15.0.4; 15.1 to before 15.1.1 | 14.10.5, 15.0.4, 15.1.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 14.5 to before 14.10.5; 15.0 to before 15.0.4; 15.1 to before 15.1.1 Fixed in 14.10.5, 15.0.4, 15.1.1 Patch available CNA
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.10.5, 15.0.4, 15.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2235
- 2026-10-03 Alias added: GHSA-mxgw-4fpv-6f32
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2235 · CVE Program
- CVE-2022-2235 · NVD
- FIRST EPSS
- GHSA-mxgw-4fpv-6f32 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences