MailChimp for Woocommerce < 2.7.1 - Subscriber+ SSRF
Priority LOW 21CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
The Mailchimp for WooCommerce WordPress plugin before 2.7.1 has an AJAX action that allows any logged in users (such as subscriber) to perform a POST request on behalf of the server to the internal network/LAN, the body of the request is also appended to the response so it can be used to scan private network for example
Why it matters now
EPSS 0.00724 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Mailchimp for WooCommerce (Unknown): 2.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Mailchimp for WooCommerce | 2.7.1 to before 2.7.1 | 2.7.1 | Patch available | CNA |
- Mailchimp for WooCommerce VendorUnknown Affected 2.7.1 to before 2.7.1 Fixed in 2.7.1 Patch available CNA
Remediation
- Fix · CNA Mailchimp for WooCommerce (Unknown) Fixed in 2.7.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2267
- 2026-10-03 Alias added: GHSA-c7c8-3594-h7vm
References
More Mailchimp For Woocommerce vulnerabilities
- TI-2022-02361 MailChimp for Woocommerce < 2.7.2 - Admin+ SSRF CVSS 3.1LOW 2.7
Sources
- CVE-2022-2267 · CVE Program
- CVE-2022-2267 · NVD
- FIRST EPSS
- GHSA-c7c8-3594-h7vm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences