A lack of cascading deletes in GitLab CE/EE affecting all versions starting from 13.0…
Priority LOW 19CWE-459Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A lack of cascading deletes in GitLab CE/EE affecting all versions starting from 13.0 before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1 allows a malicious Group Owner to retain a usable Group Access Token even after the Group is deleted, though the APIs usable by that token are limited.
Why it matters now
EPSS 0.00558 46th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 15.0.5, 15.1.4, 15.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.0 to before 15.0.5; 15.1 to before 15.1.4; 15.2 to before 15.2.1 | 15.0.5, 15.1.4, 15.2.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.0 to before 15.0.5; 15.1 to before 15.1.4; 15.2 to before 15.2.1 Fixed in 15.0.5, 15.1.4, 15.2.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.0.0 to before 15.0.5; 15.1.0 to before 15.1.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.2:*:*:*:enterprise:*:*:* | 15.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.0.0 to before 15.0.5; 15.1.0 to before 15.1.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.2:*:*:*:community:*:*:* | 15.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.0.0 to before 15.0.5; 15.1.0 to before 15.1.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.2:*:*:*:enterprise:*:*:* Versions 15.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.0.0 to before 15.0.5; 15.1.0 to before 15.1.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.2:*:*:*:community:*:*:* Versions 15.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.0.5, 15.1.4, 15.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2307
- 2026-10-03 Alias added: GHSA-xpg3-c2hf-x9vf
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2307 · CVE Program
- CVE-2022-2307 · NVD
- FIRST EPSS
- GHSA-xpg3-c2hf-x9vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences