GNU SASL libgsasl server-side read-out-of-bounds with malicious authenticated GSS-API client
Priority LOW 38CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
GNU SASL libgsasl server-side read-out-of-bounds with malicious authenticated GSS-API client
Why it matters now
EPSS 0.01572 75th percentileScored 2026-11-07
Fix Fixed GNU SASL (GNU): 2.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GNU | GNU SASL | 0.0.0 to before 2.0.1 | 2.0.1 | Patch available | CNA |
- GNU SASL VendorGNU Affected 0.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available CNA
Remediation
- Fix · CNA GNU SASL (GNU) Fixed in 2.0.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2469
- 2026-10-03 Alias added: GHSA-r9xr-xfwx-6crw
References
Sources
- CVE-2022-2469 · CVE Program
- CVE-2022-2469 · NVD
- FIRST EPSS
- GHSA-r9xr-xfwx-6crw · GitHub Advisory Database · CC BY 4.0
- CVE-2022-2469 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences