Improper privilege management in GitLab
Priority LOW 34CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
An issue in pipeline subscriptions in GitLab EE affecting all versions from 12.8 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 triggered new pipelines with the person who created the tag as the pipeline creator instead of the subscription's author.
Why it matters now
EPSS 0.0087 59th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 15.0.5, 15.1.4, 15.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.8 to before 15.0.5; 15.1 to before 15.1.4; 15.2 to before 15.2.1 | 15.0.5, 15.1.4, 15.2.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.8 to before 15.0.5; 15.1 to before 15.1.4; 15.2 to before 15.2.1 Fixed in 15.0.5, 15.1.4, 15.2.1 Patch available CNA
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.0.5, 15.1.4, 15.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2498
- 2026-10-03 Alias added: GHSA-f5vg-g8qw-8p89
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2498 · CVE Program
- CVE-2022-2498 · NVD
- FIRST EPSS
- GHSA-f5vg-g8qw-8p89 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences