DSGVO All in one for WP < 4.2 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The DSGVO All in one for WP WordPress plugin before 4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00698 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed DSGVO All in one for WP (Unknown): 4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | DSGVO All in one for WP | 4.2 to before 4.2 | 4.2 | Patch available | CNA |
- DSGVO All in one for WP VendorUnknown Affected 4.2 to before 4.2 Fixed in 4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dsgvo-for-wp:dsgvo_all_in_one_for_wp:*:*:*:*:*:wordpress:*:* | before 4.2 | Vulnerable | Dsgvo-for-wp |
- cpe:2.3:a:dsgvo-for-wp:dsgvo_all_in_one_for_wp:*:*:*:*:*:wordpress:*:* Versions before 4.2 Vulnerable ·Dsgvo-for-wp
Remediation
- Fix · CNA DSGVO All in one for WP (Unknown) Fixed in 4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2628
- 2026-10-03 Alias added: GHSA-rfgm-65w3-3jh3
References
More Dsgvo-for-wp Dsgvo All In One For Wp vulnerabilities
- TI-2024-18570 WordPress DSGVO All in one for WP plugin <= 4.3 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2024-29553 WordPress DSGVO All in one for WP plugin <= 4.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-12398 DSGVO All in one for WP <= 4.6 - Cross-Site Request Forgery to Account Deletion CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-2628 · CVE Program
- CVE-2022-2628 · NVD
- FIRST EPSS
- GHSA-rfgm-65w3-3jh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences