Multivendor Marketplace Solution for WooCommerce < 3.8.12 - Unauthorised AJAX Calls
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering, Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-862.
Summary
The Multivendor Marketplace Solution for WooCommerce WordPress plugin before 3.8.12 is lacking authorisation and CSRF in multiple AJAX actions, which could allow any authenticated users, such as subscriber to call them and suspend vendors (reporter by the submitter) or update arbitrary order status (identified by WPScan when verifying the issue) for example. Other unauthenticated attacks are also possible, either directly or via CSRF
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Multivendor Marketplace Solution for WooCommerce – WC Marketplace | 3.8.12 to before 3.8.12 | 3.8.12 | Patch available | CNA |
- Multivendor Marketplace Solution for WooCommerce – WC Marketplace VendorUnknown Affected 3.8.12 to before 3.8.12 Fixed in 3.8.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wc-marketplace:multivendor_marketplace_solution_for_woocommerce_-_wc_marketplace:*:*:*:*:*:wordpress:*:* | before 3.8.12 | Vulnerable | Wc-marketplace |
- cpe:2.3:a:wc-marketplace:multivendor_marketplace_solution_for_woocommerce_-_wc_marketplace:*:*:*:*:*:wordpress:*:* Versions before 3.8.12 Vulnerable ·Wc-marketplace
Remediation
- Fix · CNA Multivendor Marketplace Solution for WooCommerce – WC Marketplace (Unknown) Fixed in 3.8.12
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2657
- 2026-10-03 Alias added: GHSA-952v-66g2-63pm
References
Sources
- CVE-2022-2657 · CVE Program
- CVE-2022-2657 · NVD
- FIRST EPSS
- GHSA-952v-66g2-63pm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences