WP Spell Check < 9.13 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP Spell Check WordPress plugin before 9.13 does not escape ignored words, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00475 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Spell Check (Unknown): 9.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Spell Check | before 9.13 | 9.13 | Patch available | CNA |
- WP Spell Check VendorUnknown Affected before 9.13 Fixed in 9.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpspellcheck:wpspellcheck:*:*:*:*:*:wordpress:*:* | before 9.13 | Vulnerable | WP Spell Check |
- cpe:2.3:a:wpspellcheck:wpspellcheck:*:*:*:*:*:wordpress:*:* Versions before 9.13 Vulnerable ·WP Spell Check
Remediation
- Fix · CNA WP Spell Check (Unknown) Fixed in 9.13
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2658
- 2026-10-03 Alias added: GHSA-3p9v-8h44-8rrr
References
More WP Spell Check Wpspellcheck vulnerabilities
- TI-2019-04316 Cross-site request forgery in WP Spell Check CVSS 3.1HIGH 8.8
- TI-2024-14744 WordPress WP Spell Check Plugin <= 9.17 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2658 · CVE Program
- CVE-2022-2658 · NVD
- FIRST EPSS
- GHSA-3p9v-8h44-8rrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences