Cross-site scripting in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions starting from 15.2 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 It was possible to exploit a vulnerability in the external status checks feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.4 to before 15.4.1; 15.3 to before 15.3.4; 15.2 to before 15.2.5 | 15.4.1, 15.3.4, 15.2.5 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.4 to before 15.4.1; 15.3 to before 15.3.4; 15.2 to before 15.2.5 Fixed in 15.4.1, 15.3.4, 15.2.5 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.2 to before 15.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.2 – 15.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.3 to before 15.3.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.3 – 15.3.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:community:*:*:* | 15.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:enterprise:*:*:* | 15.4 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.2 to before 15.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.2 – 15.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.3 to before 15.3.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.3 – 15.3.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:community:*:*:* Versions 15.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:enterprise:*:*:* Versions 15.4 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.4.1, 15.3.4, 15.2.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2904
- 2026-10-03 Alias added: GHSA-pfg9-h349-wqvq
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2904 · CVE Program
- CVE-2022-2904 · NVD
- FIRST EPSS
- GHSA-pfg9-h349-wqvq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences