Unverified Password Change in octoprint/octoprint
Priority LOW 34CWE-620Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Unverified Password Change in GitHub repository octoprint/octoprint prior to 1.8.3.
Why it matters now
EPSS 0.00347 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed octoprint/octoprint (octoprint): 1.8.3OctoPrint (PyPI): 1.8.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OctoPrint | octoprint/octoprint | before 1.8.3 | 1.8.3 | Patch available | CNA |
| — | OctoPrint (PyPI) | before 1.8.3 | 1.8.3 | Patch available | GHSA-39gf-864w-pxw4 |
- octoprint/octoprint VendorOctoPrint Affected before 1.8.3 Fixed in 1.8.3 Patch available CNA
- OctoPrint (PyPI) Vendor— Affected before 1.8.3 Fixed in 1.8.3 Patch available GHSA-39gf-864w-pxw4
Remediation
- Fix · CNA octoprint/octoprint (octoprint) Fixed in 1.8.3
- Fix · GHSA-39gf-864w-pxw4 OctoPrint (PyPI) Fixed in 1.8.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2930
- 2026-10-03 Alias added: GHSA-39gf-864w-pxw4
References
More Octoprint vulnerabilities
- TI-2022-02830 Improper Privilege Management in octoprint/octoprint CVSS 3.1HIGH 8.8
- TI-2022-03320 Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in octoprint/octoprint CVSS 3.1MEDIUM 6.0
- TI-2022-02664 Unrestricted Upload of File with Dangerous Type in octoprint/octoprint CVSS 3.1MEDIUM 5.4
- TI-2025-35988 OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload CVSS 4.0HIGH 7.5
- TI-2024-18796 OctoPrint XSS via the "Snapshot Test" feature in Classic Webcam plugin settings CVSS 3.1MEDIUM 4.8
- TI-2022-02678 Insufficient Session Expiration in octoprint/octoprint CVSS 3.1MEDIUM 4.4
Sources
- CVE-2022-2930 · CVE Program
- CVE-2022-2930 · NVD
- FIRST EPSS
- GHSA-39gf-864w-pxw4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences