Read the docs
TI-2022-02842 Aliases CVE-2022-3080GHSA-7mrh-jrcg-wc76

BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly

Priority MEDIUM 43CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-613.

Summary

By sending specific queries to the resolver, an attacker can cause named to crash.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02005 80th percentileScored 2026-11-07
Fix Fixed Red Hat: 2 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND9Open Source Branch 9.16 9.16.14 through versions before 9.16.33; Open Source Branch 9.18 9.18.0 through versions before 9.18.7; Supported Preview Branch 9.16-S 9.16.14-S1 through versions before 9.16.33-S1; Development Branch 9.19 9.19.0 through versions before 9.19.5—No fix listedCNA
  • BIND9 VendorISC Affected Open Source Branch 9.16 9.16.14 through versions before 9.16.33; Open Source Branch 9.18 9.18.0 through versions before 9.18.7; Supported Preview Branch 9.16-S 9.16.14-S1 through versions before 9.16.33-S1; Development Branch 9.19 9.19.0 through versions before 9.19.5 Fixed in — No fix listed CNA

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.16.14 to before 9.16.33; 9.18.0 to before 9.18.7; 9.19.0 to before 9.19.5VulnerableISC
cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:*9.16.14 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:*9.16.21 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:*9.16.32 s1VulnerableISC
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.16.14 to before 9.16.33; 9.18.0 to before 9.18.7; 9.19.0 to before 9.19.5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:* Versions 9.16.14 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:* Versions 9.16.21 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:* Versions 9.16.32 s1 Vulnerable ·ISC
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject

Remediation

Red Hat 2 advisories

  • RHSA-2022:6781 Released 2022-10-04 · Red Hat rating Important
    bind9.16 security update
    • Red Hat Enterprise Linux AppStream (v. 8) bind9.16-32:9.16.23-0.7.el8_6.1, bind9.16-chroot-32:9.16.23-0.7.el8_6.1, bind9.16-libs-32:9.16.23-0.7.el8_6.1 +2
    • Red Hat Enterprise Linux CRB (v. 8) bind9.16-devel-32:9.16.23-0.7.el8_6.1, bind9.16-dnssec-utils-32:9.16.23-0.7.el8_6.1, bind9.16-doc-32:9.16.23-0.7.el8_6.1 +2
  • RHSA-2022:6763 Released 2022-10-03 · Red Hat rating Important
    bind security update
    • Red Hat CodeReady Linux Builder (v. 9) bind-devel-32:9.16.23-1.el9_0.1, bind-libs-32:9.16.23-1.el9_0.1
    • Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-1.el9_0.1, bind-chroot-32:9.16.23-1.el9_0.1, bind-dnssec-doc-32:9.16.23-1.el9_0.1 +5

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ISC BIND9 — FEDORA-2022-ef038365de

    4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2022-17871 Memory leak in ECDSA DNSSEC verification codePriority MEDIUM 45
    • TI-2022-17872 Memory leaks in EdDSA DNSSEC verification codePriority MEDIUM 44
    • TI-2022-02590 Processing large delegations may severely degrade resolver performancePriority LOW 34
  • Advisory ·

    ISC BIND9 — FEDORA-2022-8268735e06

    4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2022-17871 Memory leak in ECDSA DNSSEC verification codePriority MEDIUM 45
    • TI-2022-17872 Memory leaks in EdDSA DNSSEC verification codePriority MEDIUM 44
    • TI-2022-02590 Processing large delegations may severely degrade resolver performancePriority LOW 34
Show 2 more groups
  • Advisory ·

    ISC BIND9 — FEDORA-2022-b197d64471

    4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2022-17871 Memory leak in ECDSA DNSSEC verification codePriority MEDIUM 45
    • TI-2022-17872 Memory leaks in EdDSA DNSSEC verification codePriority MEDIUM 44
    • TI-2022-02590 Processing large delegations may severely degrade resolver performancePriority LOW 34
  • Advisory ·

    ISC BIND9 — DSA-5235

    4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2022-17871 Memory leak in ECDSA DNSSEC verification codePriority MEDIUM 45
    • TI-2022-17872 Memory leaks in EdDSA DNSSEC verification codePriority MEDIUM 44
    • TI-2022-02590 Processing large delegations may severely degrade resolver performancePriority LOW 34

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat CodeReady Linux Builder (v. 9)Fixed RHSA-2022:6763
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2022:6781
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2022:6763
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2022:6781
Not affected: 4 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3080
  2. 2026-10-03 Alias added: GHSA-7mrh-jrcg-wc76

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources