Read the docs
TI-2022-02855 Aliases CVE-2022-3094GHSA-8f7f-g9cj-hq6g

An UPDATE message flood may cause named to exhaust all available memory

Priority MEDIUM 53CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 9 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-400.

Summary

Sending a flood of dynamic DNS updates may cause `named` to allocate large amounts of memory. This, in turn, may cause `named` to exit due to a lack of free memory. We are not aware of any cases where this has been exploited. Memory is allocated prior to the checking of access permissions (ACLs) and is retained during the processing of a dynamic update from a client whose access credentials are accepted. Memory allocated to clients that are not permitted to send updates is released immediately upon rejection. The scope of this vulnerability is limited therefore to trusted clients who are permitted to make dynamic zone changes. If a dynamic update is REFUSED, memory will be released again very quickly. Therefore it is only likely to be possible to degrade or stop `named` by sending a flood of unaccepted dynamic updates comparable in magnitude to a query flood intended to achieve the same detrimental outcome. BIND 9.11 and earlier branches are also affected, but through exhaustion of internal resources rather than memory constraints. This may reduce performance but should not be a significant problem for most servers. Therefore we don't intend to address this for BIND versions prior to BIND 9.16. This issue affects BIND 9 versions 9.16.0 through 9.16.36, 9.18.0 through 9.18.10, 9.19.0 through 9.19.8, and 9.16.8-S1 through 9.16.36-S1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.13213 96th percentileScored 2026-11-07
Fix Partial Red Hat: 5 advisoriesRed Hat: 9 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.16.0 – 9.16.36; 9.18.0 – 9.18.10; 9.19.0 – 9.19.8; 9.16.8-S1 – 9.16.36-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.16.0 – 9.16.36; 9.18.0 – 9.18.10; 9.19.0 – 9.19.8; 9.16.8-S1 – 9.16.36-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.16.0 to before 9.16.37; 9.18.0 to before 9.18.11; 9.19.0 to before 9.19.9VulnerableISC
cpe:2.3:a:isc:bind:9.16.8:s1:*:*:supported_preview:*:*:*9.16.8 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.11:s1:*:*:supported_preview:*:*:*9.16.11 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:*9.16.13 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:*9.16.14 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:*9.16.21 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:*9.16.32 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:*9.16.36 s1VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.16.0 to before 9.16.37; 9.18.0 to before 9.18.11; 9.19.0 to before 9.19.9 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.8:s1:*:*:supported_preview:*:*:* Versions 9.16.8 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.11:s1:*:*:supported_preview:*:*:* Versions 9.16.11 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:* Versions 9.16.13 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:* Versions 9.16.14 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:* Versions 9.16.21 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:* Versions 9.16.32 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:* Versions 9.16.36 s1 Vulnerable ·ISC

Remediation

Red Hat 5 advisories

  • RHSA-2024:2720 Released 2024-05-07 · Red Hat rating Important
    bind and dhcp security update
    • Red Hat Enterprise Linux AppStream EUS (v.8.6) bind-32:9.11.36-3.el8_6.7, bind-chroot-32:9.11.36-3.el8_6.7, bind-devel-32:9.11.36-3.el8_6.7 +12
    • Red Hat Enterprise Linux BaseOS EUS (v.8.6) bind-32:9.11.36-3.el8_6.7, bind-export-devel-32:9.11.36-3.el8_6.7, bind-export-libs-32:9.11.36-3.el8_6.7 +6
  • RHSA-2024:1406 Released 2024-03-19 · Red Hat rating Moderate
    bind security update
    • Red Hat Enterprise Linux AppStream EUS (v.8.8) bind-32:9.11.36-8.el8_8.3, bind-chroot-32:9.11.36-8.el8_8.3, bind-devel-32:9.11.36-8.el8_8.3 +12
    • Red Hat Enterprise Linux BaseOS EUS (v.8.8) bind-32:9.11.36-8.el8_8.3, bind-export-devel-32:9.11.36-8.el8_8.3, bind-export-libs-32:9.11.36-8.el8_8.3
  • RHSA-2023:7177 Released 2023-11-14 · Red Hat rating Moderate
    bind security update
    • Red Hat Enterprise Linux AppStream (v. 8) bind-32:9.11.36-11.el8_9, bind-chroot-32:9.11.36-11.el8_9, bind-devel-32:9.11.36-11.el8_9 +12
    • Red Hat Enterprise Linux BaseOS (v. 8) bind-32:9.11.36-11.el8_9, bind-export-devel-32:9.11.36-11.el8_9, bind-export-libs-32:9.11.36-11.el8_9
Show 2 more Red Hat advisories
  • RHSA-2023:2792 Released 2023-05-16 · Red Hat rating Moderate
    bind9.16 security and bug fix update
    • Red Hat Enterprise Linux AppStream (v. 8) bind9.16-32:9.16.23-0.14.el8, bind9.16-chroot-32:9.16.23-0.14.el8, bind9.16-dnssec-utils-32:9.16.23-0.14.el8 +4
    • Red Hat Enterprise Linux CRB (v. 8) bind9.16-devel-32:9.16.23-0.14.el8, bind9.16-doc-32:9.16.23-0.14.el8, bind9.16-libs-32:9.16.23-0.14.el8
  • RHSA-2023:2261 Released 2023-05-09 · Red Hat rating Moderate
    bind security and bug fix update
    • Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-11.el9, bind-chroot-32:9.16.23-11.el9, bind-dnssec-doc-32:9.16.23-11.el9 +5
    • Red Hat Enterprise Linux CRB (v. 9) bind-devel-32:9.16.23-11.el9, bind-doc-32:9.16.23-11.el9, bind-libs-32:9.16.23-11.el9

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:2792, RHSA-2023:7177
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:2261
Red Hat Enterprise Linux AppStream EUS (v.8.6)Fixed RHSA-2024:2720
Red Hat Enterprise Linux AppStream EUS (v.8.8)Fixed RHSA-2024:1406
Red Hat Enterprise Linux BaseOS (v. 8)Fixed RHSA-2023:7177
Red Hat Enterprise Linux BaseOS EUS (v.8.6)Fixed RHSA-2024:2720
Red Hat Enterprise Linux BaseOS EUS (v.8.8)Fixed RHSA-2024:1406
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2023:2792
Red Hat Enterprise Linux CRB (v. 9)Fixed RHSA-2023:2261
Not affected: 1 product
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3094
  2. 2026-10-03 Alias added: GHSA-8f7f-g9cj-hq6g

References

Advisory 1

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources