Macro URL arbitrary script execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 4 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-88.
Summary
LibreOffice supports Office URI Schemes to enable browser integration of LibreOffice with MS SharePoint server. An additional scheme 'vnd.libreoffice.command' specific to LibreOffice was added. In the affected versions of LibreOffice links using that scheme could be constructed to call internal macros with arbitrary arguments. Which when clicked on, or activated by document events, could result in arbitrary script execution without warning. This issue affects: The Document Foundation LibreOffice 7.4 versions prior to 7.4.1; 7.3 versions prior to 7.3.6.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| The Document Foundation | LibreOffice | 7.4 to before 7.4.1; 7.3 to before 7.3.6 | 7.4.1, 7.3.6 | Patch available | CNA |
- LibreOffice VendorThe Document Foundation Affected 7.4 to before 7.4.1; 7.3 to before 7.3.6 Fixed in 7.4.1, 7.3.6 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* | 7.3.0 to before 7.3.6 | Vulnerable | The Document Foundation |
| cpe:2.3:a:libreoffice:libreoffice:7.4.0:*:*:*:*:*:*:* | 7.4.0 | Vulnerable | The Document Foundation |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
- cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* Versions 7.3.0 to before 7.3.6 Vulnerable ·The Document Foundation
- cpe:2.3:a:libreoffice:libreoffice:7.4.0:*:*:*:*:*:*:* Versions 7.4.0 Vulnerable ·The Document Foundation
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA LibreOffice (The Document Foundation) Fixed in 7.4.1, 7.3.6
Red Hat 2 advisories
- RHSA-2023:0304 Released 2023-01-23 · Red Hat rating Moderatelibreoffice security update
- Red Hat CodeReady Linux Builder (v. 9) libreoffice-sdk-1:7.1.8.1-8.el9_1, libreoffice-sdk-doc-1:7.1.8.1-8.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) autocorr-af-1:7.1.8.1-8.el9_1, autocorr-bg-1:7.1.8.1-8.el9_1, autocorr-ca-1:7.1.8.1-8.el9_1 +47
- RHSA-2023:0089 Released 2023-01-12 · Red Hat rating Moderatelibreoffice security update
- Red Hat CodeReady Linux Builder (v. 8) libreoffice-sdk-1:6.4.7.2-12.el8_7, libreoffice-sdk-doc-1:6.4.7.2-12.el8_7
- Red Hat Enterprise Linux AppStream (v. 8) autocorr-af-1:6.4.7.2-12.el8_7, autocorr-bg-1:6.4.7.2-12.el8_7, autocorr-ca-1:6.4.7.2-12.el8_7 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2023:0089 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2023:0304 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:0089 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:0304 |
Not affected: 1 product
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3140
- 2026-10-03 Alias added: GHSA-6ggr-6xf8-p64w
References
More The Document Foundation Libreoffice vulnerabilities
- TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
- TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
- TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
- TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
- TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
- TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-3140 · CVE Program
- CVE-2022-3140 · NVD
- FIRST EPSS
- GHSA-6ggr-6xf8-p64w · GitHub Advisory Database · CC BY 4.0
- CVE-2022-3140 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences