Buffer Over-read in gpac/gpac
Priority LOW 34CWE-126Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Buffer Over-read in GitHub repository gpac/gpac prior to 2.1.0-DEV.
Why it matters now
EPSS 0.0043 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed gpac/gpac (gpac): 2.1.0-DEV
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA gpac/gpac (gpac) Fixed in 2.1.0-DEV
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3178
- 2026-10-03 Alias added: GHSA-57pm-66vj-3hh7
References
More Gpac vulnerabilities
- TI-2023-25004 An issue was discovered in gpac version 2.3-DEV-rev588-g7edc40fee-master, allows remote… CVSS 3.1CRITICAL 9.8
- TI-2025-43085 GPAC v2.4.0 was discovered to contain an out-of-bounds read in the oggdmx_parse_tags function. CVSS 3.1HIGH 8.2
- TI-2024-00295 Stack-based Buffer Overflow in gpac/gpac CVSS 3.1CRITICAL 9.8
- TI-2023-25341 Heap Buffer Overflow vulnerability in GPAC version 2.3-DEV-rev617-g671976fcc-master… CVSS 3.1CRITICAL 9.8
- TI-2023-02661 NULL Pointer Dereference in gpac/gpac CVSS 3.1CRITICAL 9.8
- TI-2026-22173 GPAC NHML Demuxer (dmx_nhml.c) Vulnerable to Stack Buffer Overflow CVSS 4.0HIGH 7.7
Sources
- CVE-2022-3178 · CVE Program
- CVE-2022-3178 · NVD
- FIRST EPSS
- GHSA-57pm-66vj-3hh7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences