AWP Classifieds Plugin < 4.3 - Unauthenticated SQLi
Priority HIGH 82CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The WordPress Classifieds Plugin WordPress plugin before 4.3 does not properly sanitise and escape some parameters before using them in a SQL statement via an AJAX action available to unauthenticated users and when a specific premium module is active, leading to a SQL injection
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.06592 93rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress Classifieds Plugin – Ad Directory & Listings by AWP Classifieds (Unknown): 4.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Classifieds Plugin – Ad Directory & Listings by AWP Classifieds | 4.3 to before 4.3 | 4.3 | Patch available | CNA |
- WordPress Classifieds Plugin – Ad Directory & Listings by AWP Classifieds VendorUnknown Affected 4.3 to before 4.3 Fixed in 4.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strategy11:awp_classifieds:*:*:*:*:*:wordpress:*:* | before 4.3 | Vulnerable | strategy11team |
- cpe:2.3:a:strategy11:awp_classifieds:*:*:*:*:*:wordpress:*:* Versions before 4.3 Vulnerable ·strategy11team
Remediation
- Fix · CNA WordPress Classifieds Plugin – Ad Directory & Listings by AWP Classifieds (Unknown) Fixed in 4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3254
- 2026-10-03 Alias added: GHSA-xm5j-qjxj-574h
References
More strategy11team Awp Classifieds vulnerabilities
- TI-2014-08175 SQL injection vulnerability in the Another WordPress Classifieds Plugin plugin for… CVSS 2.0HIGH 7.5
- TI-2024-20722 WordPress AWP Classifieds plugin <= 4.3.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-22200 WordPress AWP Classifieds Plugin <= 4.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2014-08174 Cross-site scripting (XSS) vulnerability in the Another WordPress Classifieds Plugin… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2022-3254 · CVE Program
- CVE-2022-3254 · NVD
- FIRST EPSS
- GHSA-xm5j-qjxj-574h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences