Race condition in snap-confine's must_mkdir_and_open_with_perms()
Priority LOW 36CWE-362Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Race condition in snap-confine's must_mkdir_and_open_with_perms()
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00384 32nd percentileScored 2026-11-07
Fix Fixed snapd (Canonical Ltd.): 2.61.1github.com/snapcore/snapd (Go): 2.57.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | snapd | before 2.61.1 | 2.61.1 | Patch available | CNA |
| — | github.com/snapcore/snapd (Go) | before 2.57.6 | 2.57.6 | Patch available | GHSA-cjqf-877p-7m3f |
- snapd VendorCanonical Affected before 2.61.1 Fixed in 2.61.1 Patch available CNA
- github.com/snapcore/snapd (Go) Vendor— Affected before 2.57.6 Fixed in 2.57.6 Patch available GHSA-cjqf-877p-7m3f
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:snapd:*:*:*:*:*:*:*:* | before 2.61.1 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:esm:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:* | 22.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:22.10:*:*:*:-:*:*:* | 22.10 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:snapd:*:*:*:*:*:*:*:* Versions before 2.61.1 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:esm:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:* Versions 22.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:22.10:*:*:*:-:*:*:* Versions 22.10 Vulnerable ·Canonical
Remediation
- Fix · CNA snapd (Canonical Ltd.) Fixed in 2.61.1
- Fix · GHSA-cjqf-877p-7m3f github.com/snapcore/snapd (Go) Fixed in 2.57.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3328
- 2026-10-03 Alias added: GHSA-cjqf-877p-7m3f
References
Advisory 3
More Canonical Snapd vulnerabilities
- TI-2023-01437 Injection in Canonical snapd CVSS 3.1CRITICAL 10.0
- TI-2019-05192 Local privilege escalation via snapd socket CVSS 3.1CRITICAL 9.8
- TI-2024-01603 snapd allows $HOME/bin symlink CVSS 3.1HIGH 8.2
- TI-2024-04773 Improper input validation in Canonical snapd CVSS 3.1HIGH 8.1
- TI-2020-16634 Improper privilege management in Canonical snapd CVSS 3.1CRITICAL 9.3
- TI-2019-05191 Snapd seccomp filter TIOCSTI ioctl bypass CVSS 3.1HIGH 7.5
Sources
- CVE-2022-3328 · CVE Program
- CVE-2022-3328 · NVD
- FIRST EPSS
- GHSA-cjqf-877p-7m3f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences