Kadence WooCommerce Email Designer < 1.5.7 - Admin+ PHP Objection Injection
Priority HIGH 65CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The Kadence WooCommerce Email Designer WordPress plugin before 1.5.7 unserialises the content of an imported file, which could lead to PHP object injections issues when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01517 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Kadence WooCommerce Email Designer (Unknown): 1.5.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Kadence WooCommerce Email Designer | 1.5.7 to before 1.5.7 | 1.5.7 | Patch available | CNA |
- Kadence WooCommerce Email Designer VendorUnknown Affected 1.5.7 to before 1.5.7 Fixed in 1.5.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kadencewp:kadence_woocommerce_email_designer:*:*:*:*:*:wordpress:*:* | before 1.5.7 | Vulnerable | Kadence WP |
- cpe:2.3:a:kadencewp:kadence_woocommerce_email_designer:*:*:*:*:*:wordpress:*:* Versions before 1.5.7 Vulnerable ·Kadence WP
Remediation
- Fix · CNA Kadence WooCommerce Email Designer (Unknown) Fixed in 1.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3335
- 2026-10-03 Alias added: GHSA-x7wv-26j6-pwgf
References
More Kadence WP Kadence Woocommerce Email Designer vulnerabilities
- TI-2023-25509 WordPress Kadence WooCommerce Email Designer Plugin <= 1.5.11 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2022-3335 · CVE Program
- CVE-2022-3335 · NVD
- FIRST EPSS
- GHSA-x7wv-26j6-pwgf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences