Event Monster < 1.2.0 - Visitors Deletion via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Event Monster WordPress plugin before 1.2.0 does not have CSRF check when deleting visitors, which could allow attackers to make logged in admin delete arbitrary visitors via a CSRF attack
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Event Monster | before 1.2.0 | 1.2.0 | Patch available | CNA |
- Event Monster VendorUnknown Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
Remediation
- Fix · CNA Event Monster (Unknown) Fixed in 1.2.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Event Monster 1.2.0
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2022-03417 Event Monster < 1.2.1 - Admin+ SQLiPriority HIGH 67
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3336
- 2026-10-03 Alias added: GHSA-7mhf-hm4m-p9w6
References
More A WP Life Event Monster vulnerabilities
- TI-2022-03417 Event Monster < 1.2.1 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2024-04699 WordPress Event Monster Plugin <= 1.4.0 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
- TI-2024-01764 Event Monster <= 1.3.9 - Authenticated(Contributor+) PHP Object Injection via Custom Meta CVSS 3.1HIGH 7.5
- TI-2024-10560 Event monster <= 1.4.3 - Information Exposure Via Visitors List Export CVSS 3.1MEDIUM 5.3
- TI-2023-25696 WordPress Event Management Tickets Booking Plugin <= 1.3.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-3336 · CVE Program
- CVE-2022-3336 · NVD
- FIRST EPSS
- GHSA-7mhf-hm4m-p9w6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences