Official Integration for Billingo < 3.4.0 - ShopManager+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Official Integration for Billingo WordPress plugin before 3.4.0 does not sanitise and escape some of its settings, which could allow high privilege users with a role as low as Shop Manager to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Official Integration for Billingo (Unknown): 3.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Official Integration for Billingo | 3.4.0 to before 3.4.0 | 3.4.0 | Patch available | CNA |
- Official Integration for Billingo VendorUnknown Affected 3.4.0 to before 3.4.0 Fixed in 3.4.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:official_integration_for_billingo_project:official_integration_for_billingo:*:*:*:*:*:wordpress:*:* | before 3.4.0 | Vulnerable | Official Integration For Billingo Project |
- cpe:2.3:a:official_integration_for_billingo_project:official_integration_for_billingo:*:*:*:*:*:wordpress:*:* Versions before 3.4.0 Vulnerable ·Official Integration For Billingo Project
Remediation
- Fix · CNA Official Integration for Billingo (Unknown) Fixed in 3.4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3420
- 2026-10-03 Alias added: GHSA-fwvf-3f6x-3vfw
References
Sources
- CVE-2022-3420 · CVE Program
- CVE-2022-3420 · NVD
- FIRST EPSS
- GHSA-fwvf-3f6x-3vfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences