Rock Convert < 2.6.0 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Rock Convert WordPress plugin before 2.11.0 does not sanitise and escape an URL before outputting it back in an attribute when a specific widget is present on a page, leading to a Reflected Cross-Site Scripting
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Rock Convert | 2.11.0 to before 2.11.0 | 2.11.0 | Patch available | CNA |
- Rock Convert VendorUnknown Affected 2.11.0 to before 2.11.0 Fixed in 2.11.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rockcontent:rock_convert:*:*:*:*:*:wordpress:*:* | before 2.11.0 | Vulnerable | Rock Content |
- cpe:2.3:a:rockcontent:rock_convert:*:*:*:*:*:wordpress:*:* Versions before 2.11.0 Vulnerable ·Rock Content
Remediation
- Fix · CNA Rock Convert (Unknown) Fixed in 2.11.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Rock Convert 2.11.0
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2022-03178 Rock Convert < 2.11.0 - Admin+ Stored Cross-Site ScriptingPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3440
- 2026-10-03 Alias added: GHSA-6g66-cmpw-635m
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
More Rock Content Rock Convert vulnerabilities
- TI-2022-03178 Rock Convert < 2.11.0 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2022-16756 WordPress Rock Convert plugin <= 2.11.0 - Auth. Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-3440 · CVE Program
- CVE-2022-3440 · NVD
- FIRST EPSS
- GHSA-6g66-cmpw-635m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences