Bazel leaks user credentials through the remote assets API
Priority LOW 23CWE-522Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-522.
Summary
A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Fix Fixed Bazel (Google LLC): 5.3.2, 4.2.3, 3.7.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Bazel | 5.0.0 to before 5.3.2; 4.0.0 to before 4.2.3; 3.0.0 to before 3.7.2 | 5.3.2, 4.2.3, 3.7.2 | Patch available | CNA |
- Bazel VendorGoogle Affected 5.0.0 to before 5.3.2; 4.0.0 to before 4.2.3; 3.0.0 to before 3.7.2 Fixed in 5.3.2, 4.2.3, 3.7.2 Patch available CNA
Remediation
- Fix · CNA Bazel (Google LLC) Fixed in 5.3.2, 4.2.3, 3.7.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3474
References
More Google Bazel vulnerabilities
- TI-2021-05504 Code execution in VSCode-bazel via malicious Bazel config files CVSS 3.1HIGH 8.2
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences