Cross-site scripting in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in GitLab affecting all versions starting from 12.8 before 15.8.5, all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A specially crafted payload could lead to a reflected XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims on self-hosted instances running without strict CSP.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.8 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 | 15.8.5, 15.9.4, 15.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.8 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 Fixed in 15.8.5, 15.9.4, 15.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.8.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.8.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* | 15.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* | 15.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.8.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.8.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* Versions 15.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* Versions 15.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.8.5, 15.9.4, 15.10.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3513
- 2026-10-03 Alias added: GHSA-8w2x-795m-pv4v
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-3513 · CVE Program
- CVE-2022-3513 · NVD
- FIRST EPSS
- GHSA-8w2x-795m-pv4v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences