Read the docs
TI-2022-03243 Aliases CVE-2022-3515GHSA-58wq-p76f-6qjh

Integer overflow in libksba

Priority HIGH 82CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 15 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-190 and the CVSS impact.

Summary

A vulnerability was found in the Libksba library due to an integer overflow within the CRL parser. The vulnerability can be exploited remotely for code execution on the target system by passing specially crafted data to the application, for example, a malicious S/MIME attachment.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01703 77th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial Red Hat: 7 advisoriesRed Hat: 15 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—libksbaFixed in libksba v1.6.2—No fix listedCNA
  • libksba Vendor— Affected Fixed in libksba v1.6.2 Fixed in — No fix listed CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:gnupg:libksba:*:*:*:*:*:*:*:*before 1.6.3VulnerableGnuPG
cpe:2.3:a:gpg4win:gpg4win:*:*:*:*:*:*:*:*2.0.0 to before 4.1.0VulnerableGpg4win
cpe:2.3:a:gnupg:vs-desktop:*:*:*:*:*:*:*:*3.1.16 to before 3.1.26VulnerableGnuPG
cpe:2.3:a:gnupg:gnupg:*:*:*:*:lts:*:*:*2.1.0 to before 2.2.41VulnerableGnuPG
cpe:2.3:a:gnupg:gnupg:*:*:*:*:-:*:*:*2.3.0 to before 2.4.0VulnerableGnuPG
  • cpe:2.3:a:gnupg:libksba:*:*:*:*:*:*:*:* Versions before 1.6.3 Vulnerable ·GnuPG
  • cpe:2.3:a:gpg4win:gpg4win:*:*:*:*:*:*:*:* Versions 2.0.0 to before 4.1.0 Vulnerable ·Gpg4win
  • cpe:2.3:a:gnupg:vs-desktop:*:*:*:*:*:*:*:* Versions 3.1.16 to before 3.1.26 Vulnerable ·GnuPG
  • cpe:2.3:a:gnupg:gnupg:*:*:*:*:lts:*:*:* Versions 2.1.0 to before 2.2.41 Vulnerable ·GnuPG
  • cpe:2.3:a:gnupg:gnupg:*:*:*:*:-:*:*:* Versions 2.3.0 to before 2.4.0 Vulnerable ·GnuPG

Remediation

Red Hat 7 advisories

  • RHSA-2022:8598 Released 2022-11-22 · Red Hat rating Important
    Red Hat Virtualization Host security update [ovirt-4.5.3-1]
    • Red Hat Virtualization 4 Hypervisor for RHEL 8 redhat-virtualization-host-4.5.3-202211170828_8.6, redhat-virtualization-host-image-update-4.5.3-202211170828_8.6
  • RHSA-2022:7927 Released 2022-11-14 · Red Hat rating Important
    libksba security update
    • Red Hat Enterprise Linux BaseOS EUS (v.8.4) libksba-1.3.5-8.el8_4
    • Red Hat Enterprise Linux CRB EUS (v.8.4) libksba-devel-1.3.5-8.el8_4
  • RHSA-2022:7283 Released 2022-11-01 · Red Hat rating Important
    libksba security update
    • Red Hat Enterprise Linux BaseOS AUS (v. 8.2) libksba-1.3.5-8.el8_2
    • Red Hat Enterprise Linux BaseOS E4S (v. 8.2) libksba-1.3.5-8.el8_2
    • Red Hat Enterprise Linux BaseOS TUS (v. 8.2) libksba-1.3.5-8.el8_2
Show 4 more Red Hat advisories
  • RHSA-2022:7209 Released 2022-10-26 · Red Hat rating Important
    libksba security update
    • Red Hat Enterprise Linux BaseOS E4S (v. 8.1) libksba-1.3.5-8.el8_1
  • RHSA-2022:7090 Released 2022-10-24 · Red Hat rating Important
    libksba security update
    • Red Hat CodeReady Linux Builder (v. 9) libksba-devel-1.5.1-5.el9_0
    • Red Hat Enterprise Linux BaseOS (v. 9) libksba-1.5.1-5.el9_0
  • RHSA-2022:7089 Released 2022-10-24 · Red Hat rating Important
    libksba security update
    • Red Hat Enterprise Linux BaseOS (v. 8) libksba-1.3.5-8.el8_6
    • Red Hat Enterprise Linux CRB (v. 8) libksba-devel-1.3.5-8.el8_6
  • RHSA-2022:7088 Released 2022-10-24 · Red Hat rating Important
    libksba security update
    • Red Hat Enterprise Linux Client Optional (v. 7) libksba-1.3.0-6.el7_9, libksba-devel-1.3.0-6.el7_9
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) libksba-1.3.0-6.el7_9, libksba-devel-1.3.0-6.el7_9
    • Red Hat Enterprise Linux Server Optional (v. 7) libksba-1.3.0-6.el7_9, libksba-1.3.0-6.el7_9.ppc, libksba-devel-1.3.0-6.el7_9 +1
    • Red Hat Enterprise Linux Workstation Optional (v. 7) libksba-1.3.0-6.el7_9, libksba-devel-1.3.0-6.el7_9

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat CodeReady Linux Builder (v. 9)Fixed RHSA-2022:7090
Red Hat Enterprise Linux BaseOS (v. 8)Fixed RHSA-2022:7089
Red Hat Enterprise Linux BaseOS (v. 9)Fixed RHSA-2022:7090
Red Hat Enterprise Linux BaseOS AUS (v. 8.2)Fixed RHSA-2022:7283
Red Hat Enterprise Linux BaseOS E4S (v. 8.1)Fixed RHSA-2022:7209
Red Hat Enterprise Linux BaseOS E4S (v. 8.2)Fixed RHSA-2022:7283
Red Hat Enterprise Linux BaseOS EUS (v.8.4)Fixed RHSA-2022:7927
Red Hat Enterprise Linux BaseOS TUS (v. 8.2)Fixed RHSA-2022:7283
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2022:7089
Red Hat Enterprise Linux CRB EUS (v.8.4)Fixed RHSA-2022:7927
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2022:7088
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2022:7088
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2022:7088
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2022:7088
Red Hat Virtualization 4 Hypervisor for RHEL 8Fixed RHSA-2022:8598
Not affected: 1 product
  • RHEL 8-based RHEV-H for RHEV 4 (build requirements)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3515
  2. 2026-10-03 Alias added: GHSA-58wq-p76f-6qjh

References

Sources