Cross-site scripting in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions from 13.5 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. It was possible to exploit a vulnerability in setting the Jira Connect integration which could lead to a reflected XSS that allowed attackers to perform arbitrary actions on behalf of victims.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.5 to before 15.4.6; 15.5 to before 15.5.5; 15.6 to before 15.6.1 | 15.4.6, 15.5.5, 15.6.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.5 to before 15.4.6; 15.5 to before 15.5.5; 15.6 to before 15.6.1 Fixed in 15.4.6, 15.5.5, 15.6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.5.0 to before 15.4.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.5.0 to before 15.4.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.5.0 to before 15.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.5.0 to before 15.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:community:*:*:* | 15.6.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:enterprise:*:*:* | 15.6.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.5.0 to before 15.4.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.5.0 to before 15.4.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.5.0 to before 15.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.5.0 to before 15.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:community:*:*:* Versions 15.6.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:enterprise:*:*:* Versions 15.6.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.4.6, 15.5.5, 15.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3572
- 2026-10-03 Alias added: GHSA-6gf9-9hhg-h494
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-3572 · CVE Program
- CVE-2022-3572 · NVD
- FIRST EPSS
- GHSA-6gf9-9hhg-h494 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences