Jeeng Push Notifications < 2.0.4 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Jeeng Push Notifications WordPress plugin before 2.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00544 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Jeeng Push Notifications (Unknown): 2.0.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Jeeng Push Notifications | before 2.0.4 | 2.0.4 | Patch available | CNA |
- Jeeng Push Notifications VendorUnknown Affected before 2.0.4 Fixed in 2.0.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jeeng_push_notifications_project:jeeng_push_notifications:*:*:*:*:*:wordpress:*:* | before 2.0.4 | Vulnerable | Jeeng Push Notifications Project |
- cpe:2.3:a:jeeng_push_notifications_project:jeeng_push_notifications:*:*:*:*:*:wordpress:*:* Versions before 2.0.4 Vulnerable ·Jeeng Push Notifications Project
Remediation
- Fix · CNA Jeeng Push Notifications (Unknown) Fixed in 2.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3610
- 2026-10-03 Alias added: GHSA-cj2h-qx2r-hjm7
References
Sources
- CVE-2022-3610 · CVE Program
- CVE-2022-3610 · NVD
- FIRST EPSS
- GHSA-cj2h-qx2r-hjm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences