Insufficiently protected credentials in pulp_ansible
Priority MEDIUM 58CWE-256Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-256.
Summary
The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00302 23rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial pulp-ansible (PyPI): 0.15.0Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pulp_ansible | 0.15 | — | No fix listed | CNA |
| — | pulp-ansible (PyPI) | before 0.15.0 | 0.15.0 | Patch available | GHSA-qv37-mfjf-42h8 |
- pulp_ansible Vendor— Affected 0.15 Fixed in — No fix listed CNA
- pulp-ansible (PyPI) Vendor— Affected before 0.15.0 Fixed in 0.15.0 Patch available GHSA-qv37-mfjf-42h8
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pulpproject:pulp_ansible:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Pulpproject |
| cpe:2.3:a:redhat:ansible_automation_platform:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:update_infrastructure:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Red Hat |
- cpe:2.3:a:pulpproject:pulp_ansible:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Pulpproject
- cpe:2.3:a:redhat:ansible_automation_platform:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:update_infrastructure:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-qv37-mfjf-42h8 pulp-ansible (PyPI) Fixed in 0.15.0 Advisory →
Red Hat 1 advisory
- RHSA-2023:6818 Released 2023-11-08 · Red Hat rating ImportantSatellite 6.14 security and bug fix update
- Red Hat Satellite 6.14 for RHEL 8 foreman-3.7.0.9-1.el8sat, foreman-cli-3.7.0.9-1.el8sat, foreman-debug-3.7.0.9-1.el8sat +33
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix planned: Will not fix |
| Red Hat Update Infrastructure 3 for Cloud Providers | Affected | No fix yet |
| Red Hat Satellite 6.14 for RHEL 8 | Fixed | RHSA-2023:6818 |
Not affected: 1 product
- Red Hat Satellite 6.14 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3644
- 2026-10-03 Alias added: GHSA-qv37-mfjf-42h8
References
Sources
- CVE-2022-3644 · CVE Program
- CVE-2022-3644 · NVD
- FIRST EPSS
- GHSA-qv37-mfjf-42h8 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-3644 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences