Advanced Import < 1.3.8 - Arbitrary Plugin Installation & Activation via CSRF
Priority MEDIUM 62Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Advanced Import WordPress plugin before 1.3.8 does not have CSRF check when installing and activating plugins, which could allow attackers to make a logged in admin install arbitrary plugins from WordPress.org, and activate arbitrary ones from the blog via CSRF attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Advanced Import : One Click Import for WordPress or Theme Demo Data (Unknown): 1.3.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Advanced Import : One Click Import for WordPress or Theme Demo Data | before 1.3.8 | 1.3.8 | Patch available | CNA |
- Advanced Import : One Click Import for WordPress or Theme Demo Data VendorUnknown Affected before 1.3.8 Fixed in 1.3.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:addonspress:advanced_import:*:*:*:*:*:wordpress:*:* | before 1.3.8 | Vulnerable | AddonsPress |
- cpe:2.3:a:addonspress:advanced_import:*:*:*:*:*:wordpress:*:* Versions before 1.3.8 Vulnerable ·AddonsPress
Remediation
- Fix · CNA Advanced Import : One Click Import for WordPress or Theme Demo Data (Unknown) Fixed in 1.3.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3677
- 2026-10-03 Alias added: GHSA-rm98-3vrx-q6wp
References
Sources
- CVE-2022-3677 · CVE Program
- CVE-2022-3677 · NVD
- FIRST EPSS
- GHSA-rm98-3vrx-q6wp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences