Improper authorization in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. A group owner may be able to bypass External Authorization check, if it is enabled, to access git repositories and package registries by using Deploy tokens or Deploy keys .
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.9 to before 15.4.6; 15.5 to before 15.5.5; 15.6 to before 15.6.1 | 15.4.6, 15.5.5, 15.6.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.9 to before 15.4.6; 15.5 to before 15.5.5; 15.6 to before 15.6.1 Fixed in 15.4.6, 15.5.5, 15.6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.9.0 to before 15.4.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.9.0 to before 15.4.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.5.0 to before 15.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.5.0 to before 15.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:community:*:*:* | 15.6.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:enterprise:*:*:* | 15.6.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.9.0 to before 15.4.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.9.0 to before 15.4.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.5.0 to before 15.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.5.0 to before 15.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:community:*:*:* Versions 15.6.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.6.0:*:*:*:enterprise:*:*:* Versions 15.6.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.4.6, 15.5.5, 15.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3740
- 2026-10-03 Alias added: GHSA-52w5-6rqq-mwq5
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-3740 · CVE Program
- CVE-2022-3740 · NVD
- FIRST EPSS
- GHSA-52w5-6rqq-mwq5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences