WPTools < 3.43 - Subscriber+ Arbitrary Plugin Installation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352 and CWE-863.
Summary
The WP Tools Increase Maximum Limits, Repair, Server PHP Info, Javascript errors, File Permissions, Transients, Error Log WordPress plugin before 3.43 does not have proper authorisation and CSRF in an AJAX action, allowing any authenticated users, such as subscriber to call it and install and activate arbitrary plugins from wordpress.org
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Tools Increase Maximum Limits, Repair, Server PHP Info, Javascript errors, File Permissions, Transients, Error Log | before 3.43 | 3.43 | Patch available | CNA |
- WP Tools Increase Maximum Limits, Repair, Server PHP Info, Javascript errors, File Permissions, Transients, Error Log VendorUnknown Affected before 3.43 Fixed in 3.43 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wptools_project:wptools:*:*:*:*:*:wordpress:*:* | before 3.43 | Vulnerable | Wptools Project |
- cpe:2.3:a:wptools_project:wptools:*:*:*:*:*:wordpress:*:* Versions before 3.43 Vulnerable ·Wptools Project
Remediation
- Fix · CNA WP Tools Increase Maximum Limits, Repair, Server PHP Info, Javascript errors, File Permissions, Transients, Error Log (Unknown) Fixed in 3.43
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3881
- 2026-10-03 Alias added: GHSA-pf3w-64p8-hrfr
References
Sources
- CVE-2022-3881 · CVE Program
- CVE-2022-3881 · NVD
- FIRST EPSS
- GHSA-pf3w-64p8-hrfr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences