Helloprint < 1.4.7 - Reflected Cross-Site Scripting
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Helloprint WordPress plugin before 1.4.7 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00941 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Plug your WooCommerce into the largest catalog of customized print products from Helloprint (Unknown): 1.4.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Plug your WooCommerce into the largest catalog of customized print products from Helloprint | before 1.4.7 | 1.4.7 | Patch available | CNA |
- Plug your WooCommerce into the largest catalog of customized print products from Helloprint VendorUnknown Affected before 1.4.7 Fixed in 1.4.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:helloprint:helloprint:*:*:*:*:*:wordpress:*:* | before 1.4.7 | Vulnerable | helloprint |
- cpe:2.3:a:helloprint:helloprint:*:*:*:*:*:wordpress:*:* Versions before 1.4.7 Vulnerable ·helloprint
Remediation
- Fix · CNA Plug your WooCommerce into the largest catalog of customized print products from Helloprint (Unknown) Fixed in 1.4.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3908
- 2026-10-03 Alias added: GHSA-g8mf-8j4g-35gm
References
More Helloprint vulnerabilities
- TI-2024-33954 WordPress Helloprint plugin <= 2.0.4 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 10.0
Sources
- CVE-2022-3908 · CVE Program
- CVE-2022-3908 · NVD
- FIRST EPSS
- GHSA-g8mf-8j4g-35gm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences