Kiali: error message spoofing in kiali ui
Priority LOW 21CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
A content spoofing vulnerability was found in Kiali. It was discovered that Kiali does not implement error handling when the page or endpoint being accessed cannot be found. This issue allows an attacker to perform arbitrary text injection when an error response is retrieved from the URL being accessed.
Why it matters now
EPSS 0.00738 54th percentileScored 2026-11-07
Fix Partial github.com/kiali/kiali (Go): 1.57.4Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Red Hat OpenShift Service Mesh 2.3 for RHEL 8 | — | 1.57.5-3 | Patch available | CNA |
| Red Hat | OpenShift Service Mesh 2.1 | — | — | No fix listed | CNA |
| — | github.com/kiali/kiali (Go) | before 1.57.4 | 1.57.4 | Patch available | GHSA-6f4m-j56w-55c3 |
- Red Hat OpenShift Service Mesh 2.3 for RHEL 8 VendorRed Hat Affected — Fixed in 1.57.5-3 Patch available CNA
- OpenShift Service Mesh 2.1 VendorRed Hat Affected — Fixed in — No fix listed CNA
- github.com/kiali/kiali (Go) Vendor— Affected before 1.57.4 Fixed in 1.57.4 Patch available GHSA-6f4m-j56w-55c3
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kiali:kiali:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | [Kiali] |
| cpe:2.3:a:redhat:openshift_service_mesh:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:8.0:*:*:*:*:*:*:* | 8.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_power_little_endian_eus:8.0:*:*:*:*:*:*:* | 8.0 | Running on | Red Hat |
- cpe:2.3:a:kiali:kiali:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·[Kiali]
- cpe:2.3:a:redhat:openshift_service_mesh:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:8.0:*:*:*:*:*:*:* Versions 8.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_power_little_endian_eus:8.0:*:*:*:*:*:*:* Versions 8.0 Running on ·Red Hat
Remediation
- Fix · GHSA-6f4m-j56w-55c3 github.com/kiali/kiali (Go) Fixed in 1.57.4 Advisory →
Red Hat 1 advisory
- RHSA-2023:0542 Released 2023-01-30 · Red Hat rating ImportantRed Hat OpenShift Service Mesh 2.3.1 Containers security update
- RHOSSM 2.3 for RHEL 8 openshift-service-mesh/istio-cni-rhel8, openshift-service-mesh/istio-rhel8-operator, openshift-service-mesh/kiali-rhel8 +4
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2.1 | Affected | No fix planned: Will not fix |
| RHOSSM 2.3 for RHEL 8 | Fixed | RHSA-2023:0542 |
Not affected: 1 product
- RHOSSM 2.3 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3962
- 2026-10-03 Alias added: GHSA-6f4m-j56w-55c3
References
Advisory 4
More Red Hat Openshift Service Mesh vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2019-06950 Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a… CVSS 3.1HIGH 7.5
- TI-2019-06949 Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a… CVSS 3.1HIGH 7.5
- TI-2019-06948 Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a… CVSS 3.1HIGH 7.5
- TI-2026-32429 Axios: Credential Theft and Response Hijacking via Prototype Pollution Gadget in Config Merge CVSS 3.1HIGH 7.7
- TI-2019-06946 Some HTTP/2 implementations are vulnerable to window size manipulation and stream… CVSS 3.1HIGH 7.5
Sources
- CVE-2022-3962 · CVE Program
- CVE-2022-3962 · NVD
- FIRST EPSS
- GHSA-6f4m-j56w-55c3 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-3962 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences