Videojs HTML5 Player < 1.1.9 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Videojs HTML5 Player WordPress plugin before 1.1.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00495 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Videojs HTML5 Player (Unknown): 1.1.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Videojs HTML5 Player | before 1.1.9 | 1.1.9 | Patch available | CNA |
- Videojs HTML5 Player VendorUnknown Affected before 1.1.9 Fixed in 1.1.9 Patch available CNA
Remediation
- Fix · CNA Videojs HTML5 Player (Unknown) Fixed in 1.1.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3985
- 2026-10-03 Alias added: GHSA-jqh4-9qpc-r65p
References
Sources
- CVE-2022-3985 · CVE Program
- CVE-2022-3985 · NVD
- FIRST EPSS
- GHSA-jqh4-9qpc-r65p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences