WP Stripe Checkout < 1.2.2.21 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP Stripe Checkout WordPress plugin before 1.2.2.21 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00495 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Stripe Checkout (Unknown): 1.2.2.21
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Stripe Checkout | before 1.2.2.21 | 1.2.2.21 | Patch available | CNA |
- WP Stripe Checkout VendorUnknown Affected before 1.2.2.21 Fixed in 1.2.2.21 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:noorsplugin:wp_stripe_checkout:*:*:*:*:*:wordpress:*:* | before 1.2.2.21 | Vulnerable | Noorsplugin |
- cpe:2.3:a:noorsplugin:wp_stripe_checkout:*:*:*:*:*:wordpress:*:* Versions before 1.2.2.21 Vulnerable ·Noorsplugin
Remediation
- Fix · CNA WP Stripe Checkout (Unknown) Fixed in 1.2.2.21
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3986
- 2026-10-03 Alias added: GHSA-r4w2-7j6f-m622
References
More Noorsplugin Wp Stripe Checkout vulnerabilities
- TI-2023-28580 WordPress WP Stripe Checkout Plugin <= 1.2.2.37 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
Sources
- CVE-2022-3986 · CVE Program
- CVE-2022-3986 · NVD
- FIRST EPSS
- GHSA-r4w2-7j6f-m622 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences