Image Hover Effects < 5.5 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Image Hover Effects WordPress plugin before 5.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00559 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Image Hover Effects (Unknown): 5.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Image Hover Effects | before 5.5 | 5.5 | Patch available | CNA |
- Image Hover Effects VendorUnknown Affected before 5.5 Fixed in 5.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webdevocean:image_hover_effects:*:*:*:*:*:wordpress:*:* | up to 5.3 | Vulnerable | labibahmed42 |
- cpe:2.3:a:webdevocean:image_hover_effects:*:*:*:*:*:wordpress:*:* Versions up to 5.3 Vulnerable ·labibahmed42
Remediation
- Fix · CNA Image Hover Effects (Unknown) Fixed in 5.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4010
- 2026-10-03 Alias added: GHSA-2777-r28v-7m99
References
More labibahmed42 Image Hover Effects vulnerabilities
- TI-2023-25721 WordPress Image Hover Effects Plugin <= 5.5 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2022-4010 · CVE Program
- CVE-2022-4010 · NVD
- FIRST EPSS
- GHSA-2777-r28v-7m99 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences