Cryptocurrency Widgets Pack < 2.0 - Unauthenticated SQLi
Priority HIGH 82CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The Cryptocurrency Widgets Pack WordPress plugin before 2.0 does not sanitise and escape some parameter before using it in a SQL statement via an AJAX action available to unauthenticated users, leading to a SQL injection.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0509 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Cryptocurrency Widgets Pack (Unknown): 2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Cryptocurrency Widgets Pack | before 2.0 | 2.0 | Patch available | CNA |
- Cryptocurrency Widgets Pack VendorUnknown Affected before 2.0 Fixed in 2.0 Patch available CNA
Remediation
- Fix · CNA Cryptocurrency Widgets Pack (Unknown) Fixed in 2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4059
- 2026-10-03 Alias added: GHSA-g37r-pfrh-94h3
References
More Blocksera Cryptocurrency Widgets Pack vulnerabilities
- TI-2022-21925 WordPress Cryptocurrency Widgets Pack Plugin <=1.8.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-4059 · CVE Program
- CVE-2022-4059 · NVD
- FIRST EPSS
- GHSA-g37r-pfrh-94h3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences