InPost Gallery < 2.1.4.1 - Unauthenticated LFI to RCE
Priority HIGH 82CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The InPost Gallery WordPress plugin before 2.1.4.1 insecurely uses PHP's extract() function when rendering HTML views, allowing attackers to force the inclusion of malicious files & URLs, which may enable them to run code on servers.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.10177 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed InPost Gallery (Unknown): 2.1.4.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | InPost Gallery | before 2.1.4.1 | 2.1.4.1 | Patch available | CNA |
- InPost Gallery VendorUnknown Affected before 2.1.4.1 Fixed in 2.1.4.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pluginus:inpost_gallery:*:*:*:*:*:wordpress:*:* | before 2.1.4.1 | Vulnerable | realmag777 |
- cpe:2.3:a:pluginus:inpost_gallery:*:*:*:*:*:wordpress:*:* Versions before 2.1.4.1 Vulnerable ·realmag777
Remediation
- Fix · CNA InPost Gallery (Unknown) Fixed in 2.1.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4063
- 2026-10-03 Alias added: GHSA-5rmh-7p7v-fmfc
References
More realmag777 Inpost Gallery vulnerabilities
- TI-2023-13184 Cross-site scripting in InPost Gallery WordPress Plugin CVSS 3.1MEDIUM 5.4
- TI-2024-10193 Code injection in realmag777 InPost Gallery CVSS 3.1MEDIUM 6.3
Sources
- CVE-2022-4063 · CVE Program
- CVE-2022-4063 · NVD
- FIRST EPSS
- GHSA-5rmh-7p7v-fmfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences