Read the docs
TI-2022-03729 Aliases CVE-2022-4064GHSA-3xg8-cc8f-9wv2

Dalli Meta Protocol request_formatter.rb self.meta_set injection

Priority MEDIUM 61CWE-707Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01398 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed dalli (RubyGems): 3.2.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Dalli3.2.0; 3.2.1; 3.2.2—No fix listedCNA
—dalli (RubyGems)before 3.2.33.2.3Patch availableGHSA-3xg8-cc8f-9wv2
  • Dalli Vendor— Affected 3.2.0; 3.2.1; 3.2.2 Fixed in — No fix listed CNA
  • dalli (RubyGems) Vendor— Affected before 3.2.3 Fixed in 3.2.3 Patch available GHSA-3xg8-cc8f-9wv2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dalli_project:dalli:*:*:*:*:*:ruby:*:*- to before 3.2.3VulnerableDalli Project
  • cpe:2.3:a:dalli_project:dalli:*:*:*:*:*:ruby:*:* Versions - to before 3.2.3 Vulnerable ·Dalli Project

Remediation

  • Fix · GHSA-3xg8-cc8f-9wv2 dalli (RubyGems) Fixed in 3.2.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4064
  2. 2026-10-03 Alias added: GHSA-3xg8-cc8f-9wv2

References

Sources