Incorrect authorization in GitLab
Priority HIGH 66CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
Incorrect Authorization check affecting all versions of GitLab EE from 13.11 prior to 15.5.7, 15.6 prior to 15.6.4, and 15.7 prior to 15.7.2 allows group access tokens to continue working even after the group owner loses the ability to revoke them.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00556 46th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 15.5.7, 15.6.4, 15.7.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.11 to before 15.5.7; 15.6 to before 15.6.4; 15.7 to before 15.7.2 | 15.5.7, 15.6.4, 15.7.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.11 to before 15.5.7; 15.6 to before 15.6.4; 15.7 to before 15.7.2 Fixed in 15.5.7, 15.6.4, 15.7.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.11.0 to before 15.5.7; 15.6.0 to before 15.6.4; 15.7.0 to before 15.7.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.11.0 to before 15.5.7; 15.6.0 to before 15.6.4; 15.7.0 to before 15.7.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.5.7, 15.6.4, 15.7.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4167
- 2026-10-03 Alias added: GHSA-wf4m-rq68-3mfc
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-4167 · CVE Program
- CVE-2022-4167 · NVD
- FIRST EPSS
- GHSA-wf4m-rq68-3mfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences