Multi Step Form < 1.7.8 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Multi Step Form WordPress plugin before 1.7.8 does not sanitise and escape some of its form fields, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00475 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Multi Step Form (Unknown): 1.7.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Multi Step Form | before 1.7.8 | 1.7.8 | Patch available | CNA |
- Multi Step Form VendorUnknown Affected before 1.7.8 Fixed in 1.7.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mondula:multi_step_form:*:*:*:*:*:wordpress:*:* | before 1.7.8 | Vulnerable | Mondula GmbH |
- cpe:2.3:a:mondula:multi_step_form:*:*:*:*:*:wordpress:*:* Versions before 1.7.8 Vulnerable ·Mondula GmbH
Remediation
- Fix · CNA Multi Step Form (Unknown) Fixed in 1.7.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4196
- 2026-10-03 Alias added: GHSA-5r47-3q95-vm4q
References
More Mondula GmbH Multi Step Form vulnerabilities
- TI-2024-33861 WordPress Multi Step Form plugin <= 1.7.21 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-25868 WordPress Multi Step Form Plugin <= 1.7.11 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-11529 Multi Step Form <= 1.7.23 - Missing Authorization to Unauthenticated Limited File Upload CVSS 3.1MEDIUM 5.3
- TI-2018-10345 The Mondula Multi Step Form plugin through 1.2.5 for WordPress allows XSS via the fw_data… CVSS 3.0MEDIUM 6.1
- TI-2023-27737 WordPress Multi Step Form Plugin <= 1.7.13 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2018-10668 The Mondula Multi Step Form plugin before 1.2.8 for WordPress has multiple stored XSS via wp-admin/admin-ajax.php. CVSS 3.0MEDIUM 5.4
Sources
- CVE-2022-4196 · CVE Program
- CVE-2022-4196 · NVD
- FIRST EPSS
- GHSA-5r47-3q95-vm4q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences