Read the docs
TI-2022-03897 Aliases CVE-2022-4256GHSA-mvrw-m229-pjr8

All-in-One Addons for Elementor - WidgetKit < 2.4.4 - Admin+ Stored XSS

Priority MEDIUM 55Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The All-in-One Addons for Elementor WordPress plugin before 2.4.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00493 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed All-in-One Addons for Elementor (Unknown): 2.4.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAll-in-One Addons for Elementorbefore 2.4.42.4.4Patch availableCNA
  • All-in-One Addons for Elementor VendorUnknown Affected before 2.4.4 Fixed in 2.4.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themesgrove:all-in-one_addons_for_elementor:*:*:*:*:*:wordpress:*:*before 2.4.4VulnerableThemesgrove
  • cpe:2.3:a:themesgrove:all-in-one_addons_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 2.4.4 Vulnerable ·Themesgrove

Remediation

  • Fix · CNA All-in-One Addons for Elementor (Unknown) Fixed in 2.4.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4256
  2. 2026-10-03 Alias added: GHSA-mvrw-m229-pjr8

References

  • TI-2024-24932 WordPress All-in-One Addons for Elementor – WidgetKit plugin <= 2.5.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2025-02046 Cross-site scripting in Themesgrove All-in-One Addons for Elementor – WidgetKit CVSS 3.1MEDIUM 6.4
  • TI-2024-01987 Cross-site scripting in Themesgrove All-in-One Addons for Elementor – WidgetKit CVSS 3.1MEDIUM 6.4
  • TI-2021-06559 All-in-One Addons for Elementor - WidgetKit < 2.3.10 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-09562 Information disclosure in Themesgrove All-in-One Addons for Elementor – WidgetKit CVSS 3.1MEDIUM 4.3

Sources