Cyr to Lat <= 3.5 - Authenticated SQL Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Cyr to Lat plugin for WordPress is vulnerable to authenticated SQL Injection via the 'ctl_sanitize_title' function in versions up to, and including, 3.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This potentially allows authenticated users with the ability to add or modify terms or tags to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. A partial patch became available in version 3.6 and the issue was fully patched in version 3.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ivijanstefan | Cyr to Lat Enhanced | up to 3.5 | — | No fix listed | CNA |
- Cyr to Lat Enhanced Vendorivijanstefan Affected up to 3.5 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cyr_to_lat_project:cyr_to_lat:*:*:*:*:*:wordpress:*:* | before 3.7 | Vulnerable | Cyr To Lat Project |
- cpe:2.3:a:cyr_to_lat_project:cyr_to_lat:*:*:*:*:*:wordpress:*:* Versions before 3.7 Vulnerable ·Cyr To Lat Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4290
- 2026-10-03 Alias added: GHSA-hfmf-h398-rr97
References
More ivijanstefan vulnerabilities
- TI-2026-67445 Cross-site scripting in ivijanstefan Transliterator – Multilingual and Multi-script Text… CVSS 3.1HIGH 7.2
Sources
- CVE-2022-4290 · CVE Program
- CVE-2022-4290 · NVD
- FIRST EPSS
- GHSA-hfmf-h398-rr97 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences